Improper Authentication Affecting vnc4 package, versions <4.1.1+X4.3.0-10


Severity

Recommended
0.0
high
0
10

Based on Debian security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
92.36% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-VNC4-319309
  • published15 May 2006
  • disclosed15 May 2006

Introduced: 15 May 2006

CVE-2006-2369  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Debian:10 vnc4 to version 4.1.1+X4.3.0-10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vnc4 package and not the vnc4 package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

RealVNC 4.1.1, and other products that use RealVNC such as AdderLink IP and Cisco CallManager, allows remote attackers to bypass authentication via a request in which the client specifies an insecure security type such as "Type 1 - None", which is accepted even if it is not offered by the server, as originally demonstrated using a long password.

References

CVSS Base Scores

version 3.1