Improper Verification of Cryptographic Signature Affecting apt package, versions *


0.0
low

Snyk CVSS

    Attack Complexity High
Expand this section
NVD
3.7 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-APT-522585
  • published 27 Jun 2018
  • disclosed 26 Nov 2019

How to fix?

There is no fixed version for Debian:11 apt.

NVD Description

Note: Versions mentioned in the description apply only to the upstream apt package and not the apt package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

It was found that apt-key in apt, all versions, do not correctly validate gpg keys with the master keyring, leading to a potential man-in-the-middle attack.