Improper Input Validation Affecting coreutils package, versions *


low

Snyk CVSS

    Attack Complexity Low
    Scope Changed
    Integrity High
Expand this section
NVD
6.5 medium
Expand this section
Red Hat
8.6 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-COREUTILS-514776
  • published 7 Feb 2017
  • disclosed 7 Feb 2017

How to fix?

There is no fixed version for Debian:11 coreutils.

NVD Description

Note: Versions mentioned in the description apply only to the upstream coreutils package and not the coreutils package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

chroot in GNU coreutils, when used with --userspec, allows local users to escape to the parent session via a crafted TIOCSTI ioctl call, which pushes characters to the terminal's input buffer.