CVE-2007-3564 Affecting curl package, versions <7.16.4-1



    Attack Complexity Low

    Threat Intelligence

    EPSS 1.8% (87th percentile)
Expand this section
7.3 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-CURL-521147
  • published 18 Jul 2007
  • disclosed 18 Jul 2007

How to fix?

Upgrade Debian:11 curl to version 7.16.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream curl package and not the curl package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

libcurl 7.14.0 through 7.16.3, when built with GnuTLS support, does not check SSL/TLS certificate expiration or activation dates, which allows remote attackers to bypass certain access restrictions.