Arbitrary Code Injection Affecting devscripts package, versions <2.18.4


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
2.48% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-DEVSCRIPTS-531324
  • published11 Jul 2018
  • disclosed1 Jul 2018

Introduced: 1 Jul 2018

CVE-2018-13043  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Debian:11 devscripts to version 2.18.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream devscripts package and not the devscripts package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

scripts/grep-excuses.pl in Debian devscripts through 2.18.3 allows code execution through unsafe YAML loading because YAML::Syck is used without a configuration that prevents unintended blessing.