CVE-2025-53367 Affecting djvulibre package, versions <3.5.28-2.2~deb11u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.87% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-DJVULIBRE-10627283
  • published5 Jul 2025
  • disclosed3 Jul 2025

Introduced: 3 Jul 2025

CVE-2025-53367  (opens in a new tab)

How to fix?

Upgrade Debian:11 djvulibre to version 3.5.28-2.2~deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream djvulibre package and not the djvulibre package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

DjVuLibre is a GPL implementation of DjVu, a web-centric format for distributing documents and images. Prior to version 3.5.29, the MMRDecoder::scanruns method is affected by an OOB-write vulnerability, because it does not check that the xr pointer stays within the bounds of the allocated buffer. This can lead to writes beyond the allocated memory, resulting in a heap corruption condition. An out-of-bounds read with pr is also possible for the same reason. This issue has been patched in version 3.5.29.

CVSS Base Scores

version 3.1