CVE-2026-23868 Affecting giflib package, versions <5.1.9-2+deb11u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.15% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-GIFLIB-15471734
  • published12 Mar 2026
  • disclosed10 Mar 2026

Introduced: 10 Mar 2026

CVE-2026-23868  (opens in a new tab)

How to fix?

Upgrade Debian:11 giflib to version 5.1.9-2+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream giflib package and not the giflib package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

Giflib contains a double-free vulnerability that is the result of a shallow copy in GifMakeSavedImage and incorrect error handling. The conditions needed to trigger this vulnerability are difficult but may be possible.

CVSS Base Scores

version 3.1