Buffer Overflow Affecting libheif package, versions <1.8.0-1


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Availability High
Expand this section
NVD
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-LIBHEIF-1910705
  • published 4 Nov 2021
  • disclosed 3 Nov 2021

How to fix?

Upgrade Debian:11 libheif to version 1.8.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libheif package and not the libheif package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

Buffer overflow vulnerability in function convert_colorspace in heif_colorconversion.cc in libheif v1.6.2, allows attackers to cause a denial of service and disclose sensitive information, via a crafted HEIF file.

References