Buffer Overflow Affecting libpng1.6 package, versions *


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
NVD
5.5 medium
Expand this section
Red Hat
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-LIBPNG16-2363923
  • published 26 Jan 2022
  • disclosed 24 Aug 2022

How to fix?

There is no fixed version for Debian:11 libpng1.6.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpng1.6 package and not the libpng1.6 package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

A heap overflow flaw was found in libpngs' pngimage.c program. This flaw allows an attacker with local network access to pass a specially crafted PNG file to the pngimage utility, causing an application to crash, leading to a denial of service.