Resource Exhaustion Affecting libzstd package, versions *


low

Snyk CVSS

    Attack Complexity Low
    Availability High

    Threat Intelligence

    EPSS 0.05% (18th percentile)
Expand this section
NVD
7.5 high
Expand this section
SUSE
4.7 medium
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-LIBZSTD-5406388
  • published 4 Apr 2023
  • disclosed 31 Mar 2023

How to fix?

There is no fixed version for Debian:11 libzstd.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libzstd package and not the libzstd package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

A vulnerability was found in zstd v1.4.10, where an attacker can supply empty string as an argument to the command line tool to cause buffer overrun.