Access of Resource Using Incompatible Type ('Type Confusion') Affecting lua5.4 package, versions *


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.42% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-LUA54-2347982
  • published20 Jan 2022
  • disclosed11 Jan 2022

Introduced: 11 Jan 2022

CVE-2021-44647  (opens in a new tab)
CWE-843  (opens in a new tab)

How to fix?

There is no fixed version for Debian:11 lua5.4.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lua5.4 package and not the lua5.4 package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

Lua v5.4.3 and above are affected by SEGV by type confusion in funcnamefromcode function in ldebug.c which can cause a local denial of service.

CVSS Base Scores

version 3.1