Out-of-bounds Read Affecting lua5.4 package, versions *


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
2.98% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-LUA54-2445545
  • published9 Apr 2022
  • disclosed8 Apr 2022

Introduced: 8 Apr 2022

CVE-2022-28805  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

There is no fixed version for Debian:11 lua5.4.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lua5.4 package and not the lua5.4 package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

singlevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code.

CVSS Base Scores

version 3.1