Out-of-bounds Write Affecting lua5.4 package, versions *


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
2.84% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-LUA54-2944965
  • published7 Jul 2022
  • disclosed1 Jul 2022

Introduced: 1 Jul 2022

CVE-2022-33099  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

There is no fixed version for Debian:11 lua5.4.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lua5.4 package and not the lua5.4 package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

An issue in the component luaG_runerror of Lua v5.4.4 and below leads to a heap-buffer overflow when a recursive error occurs.

CVSS Base Scores

version 3.1