Out-of-bounds Write Affecting ncurses package, versions <6.2+20200912-1


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.8 high
Expand this section
SUSE
6.2 medium
Expand this section
Red Hat
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-NCURSES-1655741
  • published 21 Sep 2021
  • disclosed 20 Sep 2021

How to fix?

Upgrade Debian:11 ncurses to version 6.2+20200912-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ncurses package and not the ncurses package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

An issue was discovered in ncurses through v6.2-1. _nc_captoinfo in captoinfo.c has a heap-based buffer overflow.