CVE-2009-4487 Affecting nginx package, versions *


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
NVD
CVSS v3 N/A  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-NGINX-517587
  • published 13 Jan 2010
  • disclosed 13 Jan 2010

How to fix?

There is no fixed version for Debian:11 nginx.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nginx package and not the nginx package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

nginx 0.7.64 writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.