Cross-site Scripting (XSS) Affecting node-express package, versions <4.16.4-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.14% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-NODEEXPRESS-528125
  • published9 Aug 2017
  • disclosed9 Aug 2017

Introduced: 9 Aug 2017

CVE-2014-6393  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:11 node-express to version 4.16.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-express package and not the node-express package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.