Improper Certificate Validation The advisory has been revoked - it doesn't affect any version of package nomad  (opens in a new tab)


Threat Intelligence

EPSS
0.98% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-NOMAD-585910
  • published1 Feb 2020
  • disclosed31 Jan 2020

Introduced: 31 Jan 2020

CVE-2020-7956  (opens in a new tab)
CWE-295  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:11.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nomad package and not the nomad package as distributed by Debian.

HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.