CVE-2026-7210 Affecting python3.9 package, versions *


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.67% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-PYTHON39-16747073
  • published18 May 2026
  • disclosed11 May 2026

Introduced: 11 May 2026

CVE-2026-7210  (opens in a new tab)

How to fix?

There is no fixed version for Debian:11 python3.9.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python3.9 package and not the python3.9 package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

xml.parsers.expat and xml.etree.ElementTree use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.

CVSS Base Scores

version 3.1