CVE-2025-9943 Affecting shibboleth-sp package, versions <3.2.2+dfsg1-1+deb11u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.41% (35th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-SHIBBOLETHSP-12613594
  • published11 Sept 2025
  • disclosed10 Sept 2025

Introduced: 10 Sep 2025

CVE-2025-9943  (opens in a new tab)

How to fix?

Upgrade Debian:11 shibboleth-sp to version 3.2.2+dfsg1-1+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shibboleth-sp package and not the shibboleth-sp package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

An SQL injection vulnerability has been identified in the "ID" attribute of the SAML response when the replay cache of the Shibboleth Service Provider (SP) is configured to use an SQL database as storage service. An unauthenticated attacker can exploit this issue via blind SQL injection, allowing for the extraction of arbitrary data from the database, if the database connection is configured to use the ODBC plugin. The vulnerability arises from insufficient escaping of single quotes in the class SQLString (file odbc-store.cpp, lines 253-271).

This issue affects Shibboleth Service Provider through 3.5.0.

CVSS Base Scores

version 3.1