Cleartext Transmission of Sensitive Information Affecting shotwell package, versions <0.25.4+really0.24.5-0.1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.21% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-SHOTWELL-528094
  • published17 Jul 2017
  • disclosed17 Jul 2017

Introduced: 17 Jul 2017

CVE-2017-1000024  (opens in a new tab)
CWE-319  (opens in a new tab)

How to fix?

Upgrade Debian:11 shotwell to version 0.25.4+really0.24.5-0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shotwell package and not the shotwell package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

Shotwell version 0.24.4 or earlier and 0.25.3 or earlier is vulnerable to an information disclosure in the web publishing plugins resulting in potential password and oauth token plaintext transmission