Improper Input Validation Affecting subversion package, versions <1.7.5-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
31.47% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-SUBVERSION-532234
  • published31 Jul 2013
  • disclosed31 Jul 2013

Introduced: 31 Jul 2013

CVE-2013-2088  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:11 subversion to version 1.7.5-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream subversion package and not the subversion package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

contrib/hook-scripts/svn-keyword-check.pl in Subversion before 1.6.23 allows remote authenticated users with commit permissions to execute arbitrary commands via shell metacharacters in a filename.

CVSS Base Scores

version 3.1