Out-of-Bounds Affecting exim4 package, versions <4.80-5.1


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
NVD  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN12-EXIM4-1544805
  • published 31 Oct 2012
  • disclosed 31 Oct 2012

How to fix?

Upgrade Debian:12 exim4 to version 4.80-5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See How to fix? for Debian:12 relevant versions.

Heap-based buffer overflow in the dkim_exim_query_dns_txt function in dkim.c in Exim 4.70 through 4.80, when DKIM support is enabled and acl_smtp_connect and acl_smtp_rcpt are not set to "warn control = dkim_disable_verify," allows remote attackers to execute arbitrary code via an email from a malicious DNS server.