Improper Input Validation Affecting gnome-keyring package, versions <3.8.2-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.54% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-GNOMEKEYRING-1547436
  • published27 Jun 2018
  • disclosed20 Dec 2019

Introduced: 27 Jun 2018

CVE-2012-6111  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:12 gnome-keyring to version 3.8.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnome-keyring package and not the gnome-keyring package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

gnome-keyring does not discard stored secrets when using gnome_keyring_lock_all_sync function

CVSS Base Scores

version 3.1