CVE-2026-93285 Affecting linux-6.12 package, versions <6.12.113-1~deb12u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.17% (6th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-LINUX612-21434912
  • published23 Oct 2026
  • disclosed24 Sept 2026

Introduced: 24 Sep 2026

CVE-2026-93285  (opens in a new tab)

How to fix?

Upgrade Debian:12 linux-6.12 to version 6.12.113-1~deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-6.12 package and not the linux-6.12 package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

In the Linux kernel, the following vulnerability has been resolved:

f2fs: embed f2fs_gc_kthread in f2fs_sb_info

Instead of allocating f2fs_gc_kthread dynamically, embed it in f2fs_sb_info. This simplifies lifetime management and prepares for fixing race conditions during teardown.

  • __sbi_store - remount|shutdown - f2fs_stop_gc_thread
  • access sbi->gc_thread - sbi->gc_thread = NULL
  • access sbi->gc_thread->f2fs_gc_task

CVSS Base Scores

version 3.1