Cross-site Scripting (XSS) Affecting node-express package, versions *


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.49% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-NODEEXPRESS-7931050
  • published11 Sept 2024
  • disclosed10 Sept 2024

Introduced: 10 Sep 2024

CVE-2024-43796  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

There is no fixed version for Debian:12 node-express.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-express package and not the node-express package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Express.js minimalist web framework for node. In express < 4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code. This issue is patched in express 4.20.0.

CVSS Base Scores

version 3.1