Improper Input Validation Affecting node-minimatch package, versions <3.0.3-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.5% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-NODEMINIMATCH-1554747
  • published31 May 2018
  • disclosed31 May 2018

Introduced: 31 May 2018

CVE-2016-10540  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Debian:12 node-minimatch to version 3.0.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-minimatch package and not the node-minimatch package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Minimatch is a minimal matching utility that works by converting glob expressions into JavaScript RegExp objects. The primary function, minimatch(path, pattern) in Minimatch 3.0.1 and earlier is vulnerable to ReDoS in the pattern parameter.