Out-of-Bounds Affecting pcsc-lite package, versions <1.5.5-4


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.5% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PCSCLITE-1556385
  • published18 Jan 2011
  • disclosed18 Jan 2011

Introduced: 18 Jan 2011

CVE-2010-4531  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:12 pcsc-lite to version 1.5.5-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcsc-lite package and not the pcsc-lite package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Stack-based buffer overflow in the ATRDecodeAtr function in the Answer-to-Reset (ATR) Handler (atrhandler.c) for pcscd in PCSC-Lite 1.5.3, and possibly other 1.5.x and 1.6.x versions, allows physically proximate attackers to cause a denial of service (crash) and possibly execute arbitrary code via a smart card with an ATR message containing a long attribute value.

CVSS Base Scores

version 3.1