Interpretation Conflict Affecting php-guzzlehttp-psr7 package, versions *


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.32% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PHPGUZZLEHTTPPSR7-17896860
  • published9 Jul 2026
  • disclosed8 Jul 2026

Introduced: 8 Jul 2026

CVE-2026-59882  (opens in a new tab)
CWE-436  (opens in a new tab)

How to fix?

There is no fixed version for Debian:12 php-guzzlehttp-psr7.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-guzzlehttp-psr7 package and not the php-guzzlehttp-psr7 package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Prior to 2.12.3, Uri::assertValidHost() does not reject URI host components containing authority delimiters, embedded ports, or malformed IPv6 brackets, allowing Uri::getHost() to disagree with the URI authority used for security or routing decisions. This issue is fixed in version 2.12.3.

CVSS Base Scores

version 3.1