CVE-2020-7943 Affecting puppetdb package, versions <7.11.2-2


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
7.67% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PUPPETDB-3153508
  • published26 Mar 2020
  • disclosed11 Mar 2020

Introduced: 11 Mar 2020

CVE-2020-7943  (opens in a new tab)

How to fix?

Upgrade Debian:12 puppetdb to version 7.11.2-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream puppetdb package and not the puppetdb package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Puppet Server and PuppetDB provide useful performance and debugging information via their metrics API endpoints. For PuppetDB this may contain things like hostnames. Puppet Server reports resource names and titles for defined types (which may contain sensitive information) as well as function names and class names. Previously, these endpoints were open to the local network. PE 2018.1.13 & 2019.5.0, Puppet Server 6.9.2 & 5.3.12, and PuppetDB 6.9.1 & 5.2.13 disable trapperkeeper-metrics /v1 metrics API and only allows /v2 access on localhost by default. This affects software versions: Puppet Enterprise 2018.1.x stream prior to 2018.1.13 Puppet Enterprise prior to 2019.5.0 Puppet Server prior to 6.9.2 Puppet Server prior to 5.3.12 PuppetDB prior to 6.9.1 PuppetDB prior to 5.2.13 Resolved in: Puppet Enterprise 2018.1.13 Puppet Enterprise 2019.5.0 Puppet Server 6.9.2 Puppet Server 5.3.12 PuppetDB 6.9.1 PuppetDB 5.2.13

CVSS Base Scores

version 3.1