Improper Input Validation Affecting radsecproxy package, versions <1.8.2-4


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.34% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-RADSECPROXY-1558537
  • published27 May 2021
  • disclosed28 May 2021

Introduced: 27 May 2021

CVE-2021-32642  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:12 radsecproxy to version 1.8.2-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream radsecproxy package and not the radsecproxy package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

radsecproxy is a generic RADIUS proxy that supports both UDP and TLS (RadSec) RADIUS transports. Missing input validation in radsecproxy's naptr-eduroam.sh and radsec-dynsrv.sh scripts can lead to configuration injection via crafted radsec peer discovery DNS records. Users are subject to Information disclosure, Denial of Service, Redirection of Radius connection to a non-authenticated server leading to non-authenticated network access. Updated example scripts are available in the master branch and 1.9 release. Note that the scripts are not part of the installation package and are not updated automatically. If you are using the examples, you have to update them manually. The dyndisc scripts work independently of the radsecproxy code. The updated scripts can be used with any version of radsecproxy.

CVSS Base Scores

version 3.1