Improper Certificate Validation Affecting shotwell package, versions <0.22.0-3


Severity

Recommended
0.0
low
0
10

Based on Debian security rating.

Threat Intelligence

EPSS
0.87% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-SHOTWELL-1559300
  • published25 Oct 2016
  • disclosed25 Oct 2016

Introduced: 25 Oct 2016

CVE-2016-1000033  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Debian:12 shotwell to version 0.22.0-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shotwell package and not the shotwell package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Shotwell version 0.22.0 (and possibly other versions) is vulnerable to a TLS/SSL certification validation flaw resulting in a potential for man in the middle attacks.

CVSS Base Scores

version 3.1