XML External Entity (XXE) Injection Affecting simplesamlphp package, versions <1.19.7-1+deb12u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.43% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-SIMPLESAMLPHP-8453836
  • published4 Dec 2024
  • disclosed2 Dec 2024

Introduced: 2 Dec 2024

CVE-2024-52806  (opens in a new tab)
CWE-611  (opens in a new tab)

How to fix?

Upgrade Debian:12 simplesamlphp to version 1.19.7-1+deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream simplesamlphp package and not the simplesamlphp package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. This vulnerability is fixed in 4.6.14 and 5.0.0-alpha.18.