Double Free Affecting strongswan package, versions <5.9.8-5+deb12u5


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.42% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-STRONGSWAN-17240096
  • published9 Jun 2026
  • disclosed22 Aug 2026

Introduced: 9 Jun 2026

CVE-2026-47895  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Debian:12 strongswan to version 5.9.8-5+deb12u5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream strongswan package and not the strongswan package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

In strongSwan before 6.0.7, identity parsing/cloning is mishandled. Parsed EAP-Identities that result in an empty but non-NULL encoding are not correctly cloned and trigger a double-free once the duplicates are destroyed.

CVSS Base Scores

version 3.1