Out-of-bounds Write The advisory has been revoked - it doesn't affect any version of package suricata  (opens in a new tab)


Threat Intelligence

EPSS
0.39% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-SURICATA-14139367
  • published28 Nov 2025
  • disclosed26 Nov 2025

Introduced: 26 Nov 2025

CVE-2025-64332  (opens in a new tab)
CWE-787  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:12.

NVD Description

Note: Versions mentioned in the description apply only to the upstream suricata package and not the suricata package as distributed by Debian.

Suricata is a network IDS, IPS and NSM engine developed by the OISF (Open Information Security Foundation) and the Suricata community. Prior to versions 7.0.13 and 8.0.2, a stack overflow that causes Suricata to crash can occur if SWF decompression is enabled. This issue has been patched in versions 7.0.13 and 8.0.2. A workaround for this issue involves disabling SWF decompression (swf-decompression in suricata.yaml), it is disabled by default; set decompress-depth to lower than half your stack size if swf-decompression must be enabled.