Improper Input Validation Affecting taglib package, versions <1.7.1-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
3.1% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-TAGLIB-1560150
  • published6 Sept 2012
  • disclosed6 Sept 2012

Introduced: 6 Sep 2012

CVE-2012-1108  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:12 taglib to version 1.7.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream taglib package and not the taglib package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

The parse function in ogg/xiphcomment.cpp in TagLib 1.7 and earlier allows remote attackers to cause a denial of service (crash) via a crafted vendorLength field in an ogg file.

CVSS Base Scores

version 3.1