Improper Input Validation Affecting weechat package, versions <0.2.6.1-1


Severity

Recommended
0.0
medium
0
10

Based on Debian security rating.

Threat Intelligence

EPSS
3.11% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-WEECHAT-1562461
  • published19 Mar 2009
  • disclosed19 Mar 2009

Introduced: 19 Mar 2009

CVE-2009-0661  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:12 weechat to version 0.2.6.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream weechat package and not the weechat package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

Wee Enhanced Environment for Chat (WeeChat) 0.2.6 allows remote attackers to cause a denial of service (crash) via an IRC PRIVMSG command containing crafted color codes that trigger an out-of-bounds read.

CVSS Base Scores

version 3.1