Directory Traversal Affecting devscripts package, versions <2.14.8


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
3.73% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-DEVSCRIPTS-5674352
  • published5 Feb 2014
  • disclosed5 Feb 2014

Introduced: 5 Feb 2014

CVE-2014-1833  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:13 devscripts to version 2.14.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream devscripts package and not the devscripts package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Directory traversal vulnerability in uupdate in devscripts 2.14.1 allows remote attackers to modify arbitrary files via a crafted .orig.tar file, related to a symlink.

CVSS Base Scores

version 3.1