OS Command Injection Affecting electrum package, versions <3.2.3-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.48% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-ELECTRUM-5678021
  • published27 Jan 2018
  • disclosed27 Jan 2018

Introduced: 27 Jan 2018

CVE-2018-6353  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Debian:13 electrum to version 3.2.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream electrum package and not the electrum package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

The Python console in Electrum through 2.9.4 and 3.x through 3.0.5 supports arbitrary Python code without considering (1) social-engineering attacks in which a user pastes code that they do not understand and (2) code pasted by a physically proximate attacker at an unattended workstation, which makes it easier for attackers to steal Bitcoin via hook code that runs at a later time when the wallet password has been entered, a different vulnerability than CVE-2018-1000022.