Buffer Overflow Affecting firebird3.0 package, versions *


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.54% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-FIREBIRD30-16100481
  • published18 Apr 2026
  • disclosed17 Apr 2026

Introduced: 17 Apr 2026

CVE-2026-33337  (opens in a new tab)
CWE-120  (opens in a new tab)
CWE-502  (opens in a new tab)

How to fix?

There is no fixed version for Debian:13 firebird3.0.

NVD Description

Note: Versions mentioned in the description apply only to the upstream firebird3.0 package and not the firebird3.0 package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, when deserializing a slice packet, the xdr_datum() function does not validate that a cstring length conforms to the slice descriptor bounds, allowing a cstring longer than the allocated buffer to overflow it. An unauthenticated attacker can exploit this by sending a crafted packet to the server, potentially causing a crash or other security impact. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.

CVSS Base Scores

version 3.1