Arbitrary Code Injection Affecting gnome-shell package, versions <3.34.0-2


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.29% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-GNOMESHELL-5681327
  • published1 Oct 2012
  • disclosed1 Oct 2012

Introduced: 1 Oct 2012

CVE-2012-4427  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Debian:13 gnome-shell to version 3.34.0-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnome-shell package and not the gnome-shell package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

The gnome-shell plugin 3.4.1 in GNOME allows remote attackers to force the download and installation of arbitrary extensions from extensions.gnome.org via a crafted web page.

CVSS Base Scores

version 3.1