CVE-2022-30322 The advisory has been revoked - it doesn't affect any version of package golang-github-hashicorp-go-getter  (opens in a new tab)


Threat Intelligence

EPSS
1.46% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-GOLANGGITHUBHASHICORPGOGETTER-5681414
  • published26 May 2022
  • disclosed25 May 2022

Introduced: 25 May 2022

CVE-2022-30322  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:13.

NVD Description

Note: Versions mentioned in the description apply only to the upstream golang-github-hashicorp-go-getter package and not the golang-github-hashicorp-go-getter package as distributed by Debian.

go-getter up to 1.5.11 and 2.0.2 allowed asymmetric resource exhaustion when go-getter processed malicious HTTP responses. Fixed in 1.6.1 and 2.1.0.