CVE-2024-56431 Affecting libtheora package, versions <1.2.0~alpha1+dfsg-6


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.84% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-LIBTHEORA-8551042
  • published26 Dec 2024
  • disclosed25 Dec 2024

Introduced: 25 Dec 2024

CVE-2024-56431  (opens in a new tab)

How to fix?

Upgrade Debian:13 libtheora to version 1.2.0~alpha1+dfsg-6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libtheora package and not the libtheora package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

oc_huff_tree_unpack in huffdec.c in libtheora in Theora through 1.0 7180717 has an invalid negative left shift. NOTE: this is disputed by third parties because there is no evidence of a security impact, e.g., an application would not crash.

CVSS Base Scores

version 3.1