Information Exposure The advisory has been revoked - it doesn't affect any version of package matrix-synapse  (opens in a new tab)


Threat Intelligence

EPSS
1.45% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-MATRIXSYNAPSE-5883085
  • published1 Sept 2021
  • disclosed31 Aug 2021

Introduced: 31 Aug 2021

CVE-2021-39164  (opens in a new tab)
CWE-200  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:13.

NVD Description

Note: Versions mentioned in the description apply only to the upstream matrix-synapse package and not the matrix-synapse package as distributed by Debian.

Matrix is an ecosystem for open federated Instant Messaging and Voice over IP. In versions 1.41.0 and prior, unauthorised users can access the membership (list of members, with their display names) of a room if they know the ID of the room. The vulnerability is limited to rooms with shared history visibility. Furthermore, the unauthorised user must be using an account on a vulnerable homeserver that is in the room. Server administrators should upgrade to 1.41.1 or later in order to receive the patch. One workaround is available. Administrators of servers that use a reverse proxy could, with potentially unacceptable loss of functionality, block the endpoints: /_matrix/client/r0/rooms/{room_id}/members with at query parameter, and /_matrix/client/unstable/rooms/{room_id}/members with at query parameter.