CVE-2023-43796 The advisory has been revoked - it doesn't affect any version of package matrix-synapse  (opens in a new tab)


Threat Intelligence

EPSS
0.9% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-MATRIXSYNAPSE-6042779
  • published2 Nov 2023
  • disclosed31 Oct 2023

Introduced: 31 Oct 2023

CVE-2023-43796  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:13.

NVD Description

Note: Versions mentioned in the description apply only to the upstream matrix-synapse package and not the matrix-synapse package as distributed by Debian.

Synapse is an open-source Matrix homeserver Prior to versions 1.95.1 and 1.96.0rc1, cached device information of remote users can be queried from Synapse. This can be used to enumerate the remote users known to a homeserver. System administrators are encouraged to upgrade to Synapse 1.95.1 or 1.96.0rc1 to receive a patch. As a workaround, the federation_domain_whitelist can be used to limit federation traffic with a homeserver.