Use After Free Affecting mruby package, versions <1.3.0-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.97% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-MRUBY-5689107
  • published11 Jun 2017
  • disclosed11 Jun 2017

Introduced: 11 Jun 2017

CVE-2017-9527  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:13 mruby to version 1.3.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mruby package and not the mruby package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

The mark_context_stack function in gc.c in mruby through 1.2.0 allows attackers to cause a denial of service (heap-based use-after-free and application crash) or possibly have unspecified other impact via a crafted .rb file.

CVSS Base Scores

version 3.1