Improper Authentication Affecting oath-toolkit package, versions <2.4.1-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.88% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-OATHTOOLKIT-5691228
  • published9 Mar 2014
  • disclosed9 Mar 2014

Introduced: 9 Mar 2014

CVE-2013-7322  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Debian:13 oath-toolkit to version 2.4.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream oath-toolkit package and not the oath-toolkit package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

usersfile.c in liboath in OATH Toolkit before 2.4.1 does not properly handle lines containing an invalid one-time-password (OTP) type and a user name in /etc/users.oath, which causes the wrong line to be updated when invalidating an OTP and allows context-dependent attackers to conduct replay attacks, as demonstrated by a commented out line when using libpam-oath.

CVSS Base Scores

version 3.1