CVE-2024-47191 Affecting oath-toolkit package, versions <2.6.12-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.34% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-OATHTOOLKIT-8162603
  • published5 Oct 2024
  • disclosed9 Oct 2024

Introduced: 5 Oct 2024

CVE-2024-47191  (opens in a new tab)

How to fix?

Upgrade Debian:13 oath-toolkit to version 2.6.12-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream oath-toolkit package and not the oath-toolkit package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

pam_oath.so in oath-toolkit 2.6.7 through 2.6.11 before 2.6.12 allows root privilege escalation because, in the context of PAM code running as root, it mishandles usersfile access, such as by calling fchown in the presence of a symlink.

CVSS Base Scores

version 3.1