Symlink Following Affecting opam package, versions <2.3.0-1+deb13u2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.47% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-OPAM-17921847
  • published10 Jul 2026
  • disclosed9 Sept 2026

Introduced: 10 Jul 2026

CVE-2026-57825  (opens in a new tab)
CWE-61  (opens in a new tab)

How to fix?

Upgrade Debian:13 opam to version 2.3.0-1+deb13u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opam package and not the opam package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

In the opam package before 2.5.2 for OCaml, the sandbox protection mechanism can be bypassed because symlinks are mishandled during use of .install files.