Cryptographic Issues Affecting openssl package, versions <0.9.8b-3


Severity

Recommended
medium

Based on Debian security rating.

Threat Intelligence

EPSS
3.95% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-OPENSSL-5691814
  • published5 Sept 2006
  • disclosed5 Sept 2006

Introduced: 5 Sep 2006

CVE-2006-4339  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Debian:13 openssl to version 0.9.8b-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openssl package and not the openssl package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

A flaw was found in OpenSSL. When configured to use an RSA key with exponent 3, OpenSSL improperly removes PKCS-1 padding before generating a hash. This allows remote attackers to forge PKCS #1 v1.5 signatures. Consequently, OpenSSL may incorrectly verify X.509 and other certificates, leading to a bypass of trust and authentication mechanisms.

References

CVSS Base Scores

version 3.1