Numeric Errors Affecting pango1.0 package, versions <1.24.0-2


Severity

Recommended
0.0
medium
0
10

Based on Debian security rating.

Threat Intelligence

EPSS
4.13% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-PANGO10-5691567
  • published11 May 2009
  • disclosed11 May 2009

Introduced: 11 May 2009

CVE-2009-1194  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Debian:13 pango1.0 to version 1.24.0-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pango1.0 package and not the pango1.0 package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Integer overflow in the pango_glyph_string_set_size function in pango/glyphstring.c in Pango before 1.24 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long glyph string that triggers a heap-based buffer overflow, as demonstrated by a long document.location value in Firefox.

References

CVSS Base Scores

version 3.1